Issue Details (XML | Word | Printable)

Key: CORE-1142
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Claudio Valderrama C.
Reporter: Dmitry Yemanov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Cannot alter generator's comment to the same value

Created: 26/Feb/07 02:22 AM   Updated: 19/Aug/07 12:10 PM
Component/s: Engine
Affects Version/s: 2.0.0
Fix Version/s: 2.1 Alpha 1, 2.0.2

Time Tracking:
Not Specified

Environment: WinXP SP2
Issue Links:
Relate
 


 Description  « Hide
The issue appears only if you're attempting to set the same comment value for a generator (other object types are not affected):

comment on generator G is 'asd';
commit;
comment on generator G is 'asd';
commit;
--
Cannot commit transaction:
This operation is not defined for system tables.
unsuccessful metadata update.
GENERATOR G.
Only can modify description for user generators.

The problem is inside vio.cpp::dfw_should_know() that returns true for the "nothing changed" condition.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 19/Aug/07 12:10 PM
Fix verified, test added.