Issue Details (XML | Word | Printable)

Key: CORE-1145
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Dmitry Yemanov
Reporter: Dmitry Yemanov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Server locks up while attempting to commit a deletion of an expression index

Created: 28/Feb/07 09:14 AM   Updated: 19/Aug/07 12:13 PM
Component/s: Engine
Affects Version/s: 2.0.0
Fix Version/s: 2.1 Alpha 1, 2.0.2

Time Tracking:
Not Specified

Environment: WinXP SP2
Issue Links:
Relate
 


 Description  « Hide
The problem is related to LCK_expression locks. Index ID is not unique across database, so it shouldn't be used as a lock key.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 31/Jul/07 09:17 AM
Dmitry, could you provide a test case for this one please? I can't reproduce on 2.0.0.

Dmitry Yemanov added a comment - 01/Aug/07 03:06 AM
create table expt1 (col1 int);
create table expt2 (col2 int);
commit;

create index iexpt1 on expt1 computed (col1 + 1);
create index iexpt2 on expt2 computed (col2 + 1);
commit;

select * from expt1 where col1 + 1 = 0;
select * from expt2 where col2 + 1 = 0;
commit;

drop index iexpt2;
commit; -- lockup

Pavel Cisar added a comment - 19/Aug/07 12:13 PM
Fix verified, test added.