Issue Details (XML | Word | Printable)

Key: CORE-1165
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Claudio Valderrama C.
Reporter: Claudio Valderrama C.
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

WHEN <list of exceptions> tracks only the dependency on the first exception in PSQL.

Created: 12/Mar/07 06:45 AM   Updated: 28/Jun/07 07:46 AM
Component/s: Engine
Affects Version/s: 0.9, 0.9.4, 0.9.5, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 2.0.0, 1.5.4, 2.0.1, 2.0.2
Fix Version/s: 2.1 Beta 1

Time Tracking:
Not Specified

Environment: Operating system independent.
Issue Links:
Relate
 


 Description  « Hide
The example is silly because I had to create the simplest test case to demonstrate a bug I found in the source code:

set term ^;

drop procedure p^
recreate exception e1 'e1'^
recreate exception e2 'e2'^
create procedure p as begin
begin end
when exception e1, exception e2 do begin end
end^
show depend p^
set term ;^

The output is

        [P:Procedure]
E1:Exception
+++

The output should be instead

        [P:Procedure]
E2:Exception, E1:Exception
+++

The proof of the bug is to issue:
recreate exception e1 'e1';
recreate exception e2 'e2';

after the script shown above. Recreating e1 fails due to dependencies but recreating e2 succeeds. With correct dependencies tracking, both should fail.
In the case of
drop exception e2;
the procedure will get a BLR error the next time it's run but after all clients disconnect from the db (due to procedure caching logic).

The problem is a copy/paste in the code from par_condition into par_conditions (note singular v/s plural).
The bug predates the FB project, as seen here:
http://firebird.cvs.sourceforge.net/firebird/interbase/jrd/par.c?revision=1.1&view=markup
It was inherited from IB.

(This message is being copy/pasted, too.)


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 21/Apr/07 02:32 PM
Test added, but can't confirm the fix for 2.1 Alpha 1. Please change the fix version if this was fixed after Alpha 1, or reopen it.

Dmitry Yemanov added a comment - 21/Apr/07 02:44 PM
Set the fix version to Beta 1.

Pavel Cisar added a comment - 28/Jun/07 07:46 AM
Fix confirmed.