Issue Details (XML | Word | Printable)

Key: CORE-1199
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: skaushanskiy
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Firebird SS: internal gds software consistency check (CCH_precedence: block marked (212), file: cch.cpp line: 3640)

Created: 06/Apr/07 06:33 PM   Updated: 18/Nov/08 12:55 PM
Component/s: Engine
Affects Version/s: 2.0.0, 2.0.1, 2.0.3, 2.1 Beta 2
Fix Version/s: 2.1 RC1, 2.0.4

Time Tracking:
Not Specified

File Attachments: 1. Zip Archive gds_cch_precedence__block_marked.zip (6 kB)

Environment:
Windows XP SP2
Athlon64 X2 4400
2 GB RAM

Target: 2.1 RC1 and 2.0.4


 Description  « Hide
I started getting this error recently:
internal gds software consistency check (CCH_precedence: block marked
(212), file: cch.cpp line: 3640)

Sometimes I also get "Deadlock" messages that follow the GDS:

PDD-STAN (Server) Fri Apr 06 11:37:33 2007
Database: db
internal gds software consistency check (CCH_precedence: block marked
(212), file: cch.cpp line: 3640)


PDD-STAN (Server) Fri Apr 06 11:39:33 2007
Database: db
deadlock


PDD-STAN (Server) Fri Apr 06 11:39:33 2007
Database: db
deadlock


PDD-STAN (Server) Fri Apr 06 11:39:33 2007
Database: db
deadlock

Does anyone know what could be the cause?

I understand that I have "deadlocks" but I am
handling them in the client code. I commit the
current transaction, start a new one, and retry my
queries. I am using default transaction parameters.

This happens under load (75+ concurrent connections)
All connections are doing selects and inserts using
stored procedures. No schema modifications.

I tried all the different GCPolicies (background, cooperative and
combined) This does not seem to effect this problem.

fbclient.dll (from the FB 2.0.1 release for the client code)
FB 2.0.1 SS
Windows XP SP2
Athlon X2 4400
2GB RAM

thanks,

stan

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 09/Apr/07 08:08 AM
Are you sure that the issue (bugcheck 212) happens on v2.0.0 as well? From the first glance, I suspect a v2.0.1 regression that shouldn't exist in v2.0.0...

skaushanskiy added a comment - 09/Apr/07 08:45 PM
This just happened on V2.0.0, the log is slightly different:


PDD-STAN (Server) Mon Apr 09 19:03:22 2007
Database: C:\DB.FDB
internal gds software consistency check (CCH_precedence: block marked (212), file: cch.cpp line: 3805)

skaushanskiy added a comment - 09/Apr/07 09:45 PM
it seems to happen more ofter when I use page_size = 16384
than when I use page_size = 8192.

Vlad Khorsun added a comment - 10/Apr/07 06:59 AM
Can you make test case ?

skaushanskiy added a comment - 10/Apr/07 11:36 AM
not easily, but I will try. Do you prefer straight C/C++ API code or PHP?

Vlad Khorsun added a comment - 10/Apr/07 11:56 AM
C\C++\Delphi, please (not Delphi for PHP :)

skaushanskiy added a comment - 14/Dec/07 05:13 PM
Reproducible test case. Instructions:


Under windows with:
VS7 includes/libs/path environment variables set,
Firebird bin in path
Firebird 2.0.0 installation in c:/firebird

Run make.bat
will compile firebird_tester.cpp
will create database tester.fdb in the current directory

Create an alias to the newly created tester.fdb, called "tester"

Run: firebird_tester.exe

On my machine, I get the GDS check in 3 out of 5 times within the first minute or two.