Issue Details (XML | Word | Printable)

Key: CORE-1256
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Adriano dos Santos Fernandes
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Table columns hide destination variables of RETURNING INTO

Created: 13/May/07 11:14 AM   Updated: 26/Jul/07 09:04 AM
Component/s: Engine
Affects Version/s: 2.0.0, 2.0.1, 2.1 Initial, 2.1 Alpha 1
Fix Version/s: 2.1 Beta 1

Time Tracking:
Not Specified

Issue Links:
Relate
 


 Description  « Hide
SQL> create table t (n integer)!
SQL>
SQL> -- ok
SQL> execute block returns (n integer)
CON> as
CON> begin
CON> insert into t values (1) returning n into :n;
CON> suspend;
CON> end!

           N
============
           1

SQL> -- not ok
SQL> execute block returns (n integer)
CON> as
CON> begin
CON> insert into t values (1) returning n into n;
CON> suspend;
CON> end!

           N
============
      <null>


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 26/Jul/07 05:14 AM
I have created a test according to your specification, but I can't reproduce the bug with 2.0.1 and 2.1 Alpha 1. They return 1 like 2.1 Beta 1. I can't close it until we'll clarify it as either test case or Affected version definition is wrong.

Adriano dos Santos Fernandes added a comment - 26/Jul/07 08:29 AM
Because you wrote the test using the first statement (into :n)...
The incorrect is the second (into n).

Pavel Cisar added a comment - 26/Jul/07 09:04 AM
Fix verified for 2.1 Beta 1, test added.