Issue Details (XML | Word | Printable)

Key: CORE-1279
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Adriano dos Santos Fernandes
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Incorrect initialization of the engine with many simultaneous attachments at first time

Created: 23/May/07 07:41 PM   Updated: 14/Jun/07 09:49 PM
Component/s: None
Affects Version/s: 2.0.0, 2.0.1, 2.1 Initial
Fix Version/s: 2.1 Alpha 1, 2.0.2

Time Tracking:
Not Specified

Issue Links:
Duplicate
 


 Description  « Hide
This is in the log as reported by the user:

SKRSRV01 (Server) Sun Sep 17 18:02:47 2006
INTL plugin conflict: NONE:NONE defined in <builtin> and


SKRSRV01 (Server) Sun Sep 17 18:02:47 2006
INTL plugin conflict: OCTETS:OCTETS defined in <builtin> and


SKRSRV01 (Server) Sun Sep 17 18:02:47 2006
INTL plugin conflict: ASCII:ASCII defined in <builtin> and

.
.
.


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 25/May/07 12:57 AM
Adriano, was it really fixed in 2.1 ALPHA ? Guess it should be BETA 1 instead.

Adriano dos Santos Fernandes added a comment - 27/May/07 11:59 AM
It's 2.1 alpha 1.

Pavel Cisar added a comment - 27/May/07 12:58 PM
Ok, but I can't close the issue if there is no reproducible case or problem description clear enough to create one. How am I supposed to check the fix with description like this ? Can you fill it in, please?

Adriano dos Santos Fernandes added a comment - 27/May/07 02:07 PM
Problem may occur in a pool initialization if no attachment was done before.
This is the problem reported in fb-devel in thread "Firebird sometimes not starting correctly after server reboot":

Sometimes when we boot our server (FB2 RC4 Superserver on a Win2000
Server with 2 Xeon Processors)
we get the following messages in the firebird.log.
It's than impossible to get a connection to the server.
Can anybody tell me what this messages mean and how we can avoid this
errors ?

mfg
Carsten

SKRSRV01 (Server) Sun Sep 17 18:02:47 2006
INTL plugin conflict: NONE:NONE defined in <builtin> and


SKRSRV01 (Server) Sun Sep 17 18:02:47 2006
INTL plugin conflict: OCTETS:OCTETS defined in <builtin> and


SKRSRV01 (Server) Sun Sep 17 18:02:47 2006
INTL plugin conflict: ASCII:ASCII defined in <builtin> and

...

Pavel Cisar added a comment - 28/May/07 03:37 AM
Wonderful, so it's basically untestable, as *sometimes when we boot our server* is one hell of a description. The CVS commit was also not tagged with issue ID, so I can't even see the code for the fix.

Ok, I will take your word that's fixed, but next time please pay more attention to issue description and especially to proper CVS commit tagging. It will make our life much easier.

Adriano dos Santos Fernandes added a comment - 28/May/07 11:41 AM
Pavel, this bug was fixed in HEAD many months ago.
Fix for V2.0.2 was some days ago, with CORE-1279 in the comment, as every commit I do that was a bug registered.

If there isn't the bug number in the commit, is because there is no one registered when I commit it.

This may be due to one of this:
1) we haven't registering all bugs in the past
2) my fault
3) I didn't care to register it as I think it's not too important for that (example, HEAD regressions)
4) the many (and many) times I try to enter in the tracker and it doesn't work