Issue Details (XML | Word | Printable)

Key: CORE-1302
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Races during service startup

Created: 05/Jun/07 09:35 AM   Updated: 16/Aug/07 01:47 PM
Component/s: Engine
Affects Version/s: 1.0.3, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 2.0.0, 1.5.4, 2.0.1, 2.1 Initial, 2.1 Alpha 1
Fix Version/s: 2.1 Beta 1, 2.0.2

Time Tracking:
Not Specified

Environment: Any MT environment on SMP platform
Issue Links:
Duplicate
 


 Description  « Hide
Was detected in current HEAD, but looking at old code seems to be applicable to all firebird versions.

When starting any service in separate thread, sometimes it hangs with 100% CPU consumption (though able to serv other queries with lower efficiency).

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 06/Jun/07 03:27 AM
The problem was due to event initialized after service thread startup.
Now we use semaphore, which is much better applicable as sync for this purpose.

I do not mark 1294 as fixed now in order to let Pavel check it himself - there are still too many badly written places in services code.

Pavel Cisar added a comment - 16/Aug/07 01:47 PM
As far as I can tell, this looks fixed (cannot reproduce with 2.1 Beta 1).