Issue Details (XML | Word | Printable)

Key: CORE-1338
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Dmitry Yemanov
Reporter: ramengo
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

335544721 when selecting view with round

Created: 02/Jul/07 12:03 PM   Updated: 06/Oct/08 10:17 AM
Component/s: None
Affects Version/s: 2.1 Beta 1
Fix Version/s: 2.1 Beta 2

Time Tracking:
Not Specified

Environment: Windows XP
Issue Links:
Relate
 


 Description  « Hide
create table a (a numeric(15,15))

insert into a values(2)

create view b(a) as select round(a,2) from a

select * from b

The latter raises the following:
SQL Message : -902
Unsuccessful execution caused by a system error that precludes
successful execution of subsequent statements

Engine Code : 335544721
Engine Message :
Unable to complete network request to host "localhost".
Error reading data from the connection.

Then the Guardian blinks.


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
ramengo added a comment - 02/Jul/07 12:07 PM
Sorry, the version used is 2.1 beta1 2.1.0.15999

Maciej Kaczkowski added a comment - 26/Jul/07 07:22 AM - edited
probably any function in view make this message, for example:
create view c(a) as select dateadd(1 DAY FOR CURRENT_DATE) from a
create view d(a) as select rand() from a

and the same error message appear in computed by field
CREATE TABLE v (
  I INTEGER,
  z COMPUTED BY (RAND())
);
SELECT * FROM v;

Philippe Makowski added a comment - 06/Oct/08 10:17 AM
Q/A test ok