Issue Details (XML | Word | Printable)

Key: CORE-1371
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Viner Mihail
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Execute block fails within execute statement

Created: 20/Jul/07 04:38 AM   Updated: 29/Dec/07 11:04 AM
Component/s: None
Affects Version/s: 2.1 Beta 1
Fix Version/s: 2.0.2, 2.1 Beta 2

Time Tracking:
Not Specified

Issue Links:
Relate
 


 Description  « Hide
execute statement 'execute block as begin end';

fails with:

Unsuccessful execution caused by a system error that precludes
successful execution of subsequent statements.
Dynamic SQL Error.
SQL error code = -902.
Wrong request type in EXECUTE STATEMENT 'execute block as begin end'.

The walkaround is:
for execute statement 'execute block returns (dummy int) as begin end' into dummy do begin end

Still I think this should be fixed.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 20/Jul/07 05:45 AM
Added missing request type to list of available in EXECUTE STATEMENT.

Pavel Cisar added a comment - 29/Dec/07 11:04 AM
Verified, test added.