Issue Details (XML | Word | Printable)

Key: CORE-1548
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: fabianobonin
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Incorrect error code in GFIX

Created: 28/Oct/07 05:47 PM   Updated: 26/Dec/07 01:04 PM
Component/s: GFIX
Affects Version/s: None
Fix Version/s: 2.1 RC1

Time Tracking:
Not Specified

Environment: Linux Fedora Core 5, FB CS 2.0.3


 Description  « Hide
gfix is not returning an error code when the file is not a valid
database. Is it as designed? gbak is returning error code 1


[root@server1 firebird]# echo 1 > test.fdb
[root@server1 firebird]# gfix -v -full test.fdb
file /share/firebird/test.fdb is not a valid database
[root@server1 firebird]# echo $?
0
[root@server1 firebird]#


[root@server1 firebird]# gbak -b test.fdb test.fbk
gbak: ERROR:file /share/firebird/test.fdb is not a valid database
gbak:Exiting before completion due to errors
[root@server1 firebird]# echo $?
1
[root@server1 firebird]#

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 29/Oct/07 10:17 AM
fixed error handling in utility