Issue Details (XML | Word | Printable)

Key: CORE-1551
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

AV when all statements are cancelled

Created: 30/Oct/07 10:48 AM   Updated: 07/Oct/08 09:26 AM
Component/s: None
Affects Version/s: 2.1 Beta 2
Fix Version/s: 2.1 RC1

Time Tracking:
Not Specified

Environment: detected on posix embedded, should be reproducible in other configurations too
Issue Links:
Relate
 


 Description  « Hide
After:
# isql employee
SQL> delete from MON$STATEMENTS;
SQL> delete from MON$ATTACHMENTS;
AV happens.


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 30/Oct/07 11:00 AM
Looks like before implementation of MON$ tables nothing could make check_transaction() fail (or was never done so). In case when it failed being called from find_transaction(), error(ISC_STATUS*) was called twice, and context was released twice, and dbb_use_count was decremented also twice. Fixed use of it when called from find_transaction().

Philippe Makowski added a comment - 07/Oct/08 09:26 AM
Q/A test ok