Issue Details (XML | Word | Printable)

Key: CORE-1561
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Dmitry Yemanov
Reporter: Saulius Vabalas
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

select from mon$statements lockup

Created: 02/Nov/07 02:48 PM   Updated: 18/Nov/08 01:53 PM
Component/s: Engine
Affects Version/s: 2.1 Beta 2
Fix Version/s: 2.1 RC1

Time Tracking:
Not Specified

Environment: CS on Windows


 Description  « Hide
select from mon$statements is not responding when other connection is running high load query:

- Start two ISQL instances and connect to same DB
- on #1 connection execute statement:
  select count(*) from rdb$triggers,rdb$triggers,rdb$triggers,rdb$triggers,rdb$triggers;
- on #2 connection execute statement: select * from mon$statements;

#2 SQL will not return any results until #1 is running. This makes impossible to identify high load running queries nor any other queries when at least one of HL queries is running.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 07/Nov/07 04:29 AM
I can't reproduce it - select * from mon$statements worked fine (results shown immediately) and i have ability to kill long running statemetnt

Saulius Vabalas added a comment - 07/Nov/07 11:14 AM
Did You try it on 2.1 Beta 2 or on upcoming RC1? It could be related to CORE-1562 Dmitry fixed.

Vlad Khorsun added a comment - 08/Nov/07 05:09 AM
I tried it with current HEAD i.e. after beta 2
As for me issue is fixed