Issue Details (XML | Word | Printable)

Key: CORE-1748
Type: Bug Bug
Status: Resolved Resolved
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Igor Lobov
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Unrestorable backup

Created: 18/Feb/08 04:54 AM   Updated: 19/Jan/16 05:01 AM
Component/s: GBAK
Affects Version/s: 2.0.3, 1.5.5
Fix Version/s: 3.0 Alpha 1

File Attachments: 1. Text File test.sql (0.5 kB)

Environment: Windows, Linux
Issue Links:
Duplicate
 
Relate

QA Status: No test


 Description  « Hide
I have table with NOT NULL fields with records.
If some count of NOT NULL fields are clear I can create backup file without any errors, but can not restore it.

I attached simple script of example database.



 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Jiri Cincura added a comment - 18/Feb/08 05:06 AM
IMO it's not bug, it's by design. You have to add column and if it's NOT NULL, you have to fill it with some data yourself.

Igor Lobov added a comment - 18/Feb/08 08:05 AM - edited
Maybe it is not a bug, but it is potential hole in Firebird backup system.
I think that such defects of database must be found before or during backup process.
Prohibition to add NOT NULL fields without default values could be a solution of this problem.

Dmitry Yemanov added a comment - 18/Feb/08 11:38 PM
You *can* restore such a backup (at least since v2.0) using a "-no_validity" switch.

Csaba Lassán added a comment - 20/Feb/08 07:38 AM - edited
Dear All, in my opinion this serious bug is related more to the server core itself than the backup utility, because no one shall add "not null" columns to populated tables. If there is a way to do it, that means one can make a self-conflicting data definition!
This bug is in my 2.1.0.17735 server too.

Dmitry Yemanov added a comment - 20/Feb/08 08:03 AM
While this can be treated as a bug, this is actually the intentional behavior inherited from the very old InterBase versions.

Csaba Lassán added a comment - 20/Feb/08 09:09 AM
Dear Dmitry, may Codd bless You :D