Issue Details (XML | Word | Printable)

Key: CORE-1766
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Yakov Hrebtov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Incorrect owner and group of isc_monitor1 file on linux's classic server

Created: 28/Feb/08 01:33 AM   Updated: 18/Nov/08 01:37 PM
Component/s: Scripts
Affects Version/s: 2.1 RC2
Fix Version/s: 2.1 RC2, 2.5 Alpha 1

Time Tracking:
Not Specified

Environment: V2.1.0.17755

Planning Status: Unspecified


 Description  « Hide
Installation script of linux classic server creates isc_monitor1 file with the root owner and group. (user that runs installation procedure).
As a result, server cannot access this file, hence monitoring capabilities does not work.

The bug is caused by code in linux/classic/postinstall.sh.in and classiclibrary.sh.in.

This code from postinstall.sh.in creates and assings correct (firebird) owner on sc_init1 isc_lock1 isc_event1 files:
 
    for i in isc_init1 isc_lock1 isc_event1
      do
        FileName=$i.`hostname`
        touch $FileName
      done

    # Create log
    touch firebird.log


    # Update ownership and SUID bits for programs.
    chown -R $RunUser:$RunUser $FBRootDir

isc_monitor1 file is created next by code in function fixFilePermissions from classiclibrary.sh.in

    for i in isc_init1 isc_lock1 isc_event1 isc_monitor1
    do
        FileName=$i.`hostname`
                touch $FileName
        chmod ug=rw,o= $FileName
    done

This code is not correct as it does not change owner of touched isc_* files.
IMHO there should be only one place in code that creates all of isc_* files and assigns correct permissions to them.


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 28/Feb/08 05:17 AM
fixed install scripts