Issue Details (XML | Word | Printable)

Key: CORE-1787
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Kuznetsov Eugene
Votes: 1
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Consistency check when subquery is ordered by aggregate function from other context

Created: 11/Mar/08 04:32 PM   Updated: 21/Apr/11 07:54 AM
Component/s: Engine
Affects Version/s: 2.0.1, 2.1 Alpha 1, 2.1 Beta 1, 2.0.2, 2.0.3, 2.1 Beta 2, 2.1 RC1, 2.1 RC2
Fix Version/s: 2.5 RC1

Time Tracking:
Not Specified

Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
3-d dialect base.

CREATE TABLE TEST_TABLE1
(ID BIGINT,
 FK_ID INTEGER,
 REG_DATE TIMESTAMP NOT NULL);

COMMIT;

insert into test_table1 values (1,5,'01.01.2000');
insert into test_table1 values (2,5,'01.01.2001');
insert into test_table1 values (3,7,'01.01.2002');
insert into test_table1 values (4,8,'01.01.2003');
insert into test_table1 values (5,8,'01.01.2004');
insert into test_table1 values (6,8,'01.01.2005');
insert into test_table1 values (7,8,'01.01.2007');

COMMIT;

Now

select t.fk_id,(select first 1 t1.reg_date from test_table1 t1 where t1.fk_id = t.fk_id
                order by min(t.fk_id))
from test_table1 t
group by t.fk_id

returns error (2.1 RC2)

Unsuccessful execution caused by a system error that precludes
successful execution of subsequent statements
internal gds software consistency check (EVL_expr: invalid operation (232), file: evl.cpp line 1164)

Best regards, Eugene

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 21/Apr/11 07:54 AM
QA test added.