Issue Details (XML | Word | Printable)

Key: CORE-1798
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Adriano dos Santos Fernandes
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

RDB$DB_KEY evaluates to NULL in INSERT ... RETURNING

Created: 21/Mar/08 01:01 PM   Updated: 26/Jan/09 08:26 AM
Component/s: Engine
Affects Version/s: 2.1 RC1, 2.5 Initial, 2.1 RC2
Fix Version/s: 2.5 Alpha 1, 2.1.1

Time Tracking:
Not Specified

Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
Comment from Veselin Pavlov in CORE-1797:

I wanted to report the same issue but my use case is the following:

insert into TABLE_A(id) values (:id)
returning RDB$DB_KEY into :t_dbkey;

and "t_dbkey" is always null.

Tested with Firebird 2.1 RC2 and RC1


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Adriano dos Santos Fernandes added a comment - 21/Mar/08 01:12 PM
Since this is a V2.1 regression, I'm fixing it.

I don't think this fix alone requires another RC.

Dmitry Yemanov added a comment - 21/Mar/08 01:39 PM
Do you mean that it could be included into v2.1.0 final or deferred till v2.1.1?

Philippe Makowski added a comment - 03/Dec/08 08:49 AM
Q/A test ok