Issue Details (XML | Word | Printable)

Key: CORE-1859
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: chedek
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Arithmetic overflow or division by zero has occurred. in MAX function

Created: 23/Apr/08 03:12 PM   Updated: 26/Nov/08 06:18 AM
Component/s: None
Affects Version/s: 2.5 Initial, 2.1.0
Fix Version/s: 2.5 Alpha 1, 2.1.1

Time Tracking:
Not Specified

File Attachments: 1. Zip Archive chedeksoft.zip (493 kB)

Environment: WindowsXP,Super server, FB 2.1 final

Planning Status: Unspecified


 Description  « Hide
When I use database in ODS 11.1 with several procedures with parameters and I try to run such SQL:

select p.rdb$parameter_name,max(p.rdb$procedure_name)
from rdb$procedure_parameters p
group by 1

Server reports:
Arithmetic overflow or division by zero has occurred.
arithmetic exception, numeric overflow, or string truncation.

It's very strange because p.rdb$procedure_name is only 31 chars long.
I mean that is a problem in unicode charsers....


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 25/Apr/08 06:27 AM
Could you please provide a metadata-only backup for your database, so that we could reproduce the issue?

chedek added a comment - 25/Apr/08 08:28 AM
I sent you metadata backup

chedek added a comment - 25/Apr/08 08:28 AM
metadata backup