Issue Details (XML | Word | Printable)

Key: CORE-2089
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Unassigned
Reporter: Cosmin Apreutesei
Votes: 0
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
Firebird Core

RemoteBindAddress other than localhost makes nbackup unusable (is there already a workaround?)

Created: 17/Sep/08 11:10 PM   Updated: 07/Feb/13 11:05 AM
Component/s: NBACKUP
Affects Version/s: 2.1.1
Fix Version/s: None

Environment: linux 32bit, superserver.

Target: 3.0 Initial


 Description  « Hide
NBACKUP only works with localhost:full_db_path. This makes nbackup unusable if RemoteBindAddress is anything than localhost.

Possible workarounds:
    - make RemoteBindAddress accept a list of IP addresses to bind to instead of just one (so I can add localhost to the list, and use that with nbackup), or
    - allow nbackup to connect to hosts other than localhost like gbak does (I get it there's a request for that already, I'm not sure), or
    - allow nbackup to attach locally to the database (i.e. without hostname -- with this setup I get "cannot attach to password database" to stderr and "operating system directive semget failed" in firebird.log -- this might be a just problem with my own setup, I cannot tell for sure).

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 10/Nov/08 03:08 PM
NBACKUP is expected to work locally without problems.

Cosmin Apreutesei added a comment - 10/Nov/08 04:01 PM
I know (I read CORE-846), and yes, it works with local and localhost connection strings on both versions, but it doesn't work at all (below is which combinations I tried) if you have set RemoteBindAddress to anything _other_ than localhost (tested on 2.1.1 and 2.1.2).

So only when setting RemoteBindAddress to anything other than localhost is nbackup becoming unusable, otherwise it works fine.

Here's what I tried:

nbackup -U sysdba -P masterkey -B 0 /mydb.fdb /mydb.nbk -- unable to connect to localhost (instantly??)
nbackup -U sysdba -P masterkey -B 0 localhost:/mydb.fdb /mydb.nbk -- unable to connect to localhost (after an honest ~3s timeout)
nbackup -U sysdba -P masterkey -B 0 myhost:/mydb.fdb /mydb.nbk -- Failure: Error (2) opening database file myhost:/mydb.fdb (instantly)

If this is a known limitation then this ticket should be a request for improvement and certainly not a bug report. If that is the case then forgive my misunderstanding.


Alexander Peshkov added a comment - 11/Nov/08 11:12 AM
Since 3.0 (with always present embedded access to databases) the issue will be gone.