Issue Details (XML | Word | Printable)

Key: CORE-2157
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

fbclient does not have libpthread dependency

Created: 29/Oct/08 06:51 AM   Updated: 12/Nov/09 03:33 PM
Component/s: None
Affects Version/s: 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.1.0, 2.0.4, 2.1.1, 2.0.5
Fix Version/s: 2.1.2, 2.0.6

Time Tracking:
Not Specified

Environment: linux 32 bit

Planning Status: Unspecified


 Description  « Hide
Due to bug in gcc 3.2.x, used to build official packages (setting -pthread switch does not make output binary depend upon libpthread) problems happen when people build fbclient-dependent binaries w/o -pthread switch.

Head is free of this bug cause it can't be compiled with gcc 3.2.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 29/Oct/08 06:52 AM - edited
- - -