Issue Details (XML | Word | Printable)

Key: CORE-217
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Frank Schlottmann-Goedde
Reporter: andrewcza
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

GPRE Cobol Variable Problems

Created: 06/Mar/02 12:00 AM   Updated: 17/Mar/16 02:10 PM
Component/s: GPRE
Affects Version/s: None
Fix Version/s: 1.0.3

File Attachments: 1. Zip Archive bug_code.zip (4 kB)


SF_ID: 526204
QA Status: Cannot be tested


 Description  « Hide
SFID: 526204#
Submitted By: andrewcza

When using gpre with cobol Gpre does not always
generate the correct variable declarations.

I have attached a zip file with sample code to
duplicate and show the problem.

The Zip file contains
 esql.create.ecob (The ESQL Cobol Source)
 esql.create.ecob.cbl (The Generated code from GPRE)
 esql.insert.ecob (The EQSL Cobol Source)
 esql.insert.ecob.cbl (The Generated code from GPRE)

To Duplicate the problem run gpre as follows
gpre -co esql.create.ecob
This will Generate esql.create.ecob.cbl
Problem 1)
  edit esql.create.ecob.cbl
Line 26 reads as follows
01 isc_1db PIC X(8) VALUE IS "demo.gdb".
But in Line 77 It is called as follows
- BY REFERENCE isc-1db, BY REFERENCE
gds__database, BY VALUE 10,

The problem is that isc-1db is NOT the same as isc_1db
and gpre needs to be fixed to resolve this problem.
As a Temporary work around in My cobol Program I am
currently doing a redefine.

Problem 2)
Create a database called demo.gdb with a table called
FRIEND
CREATE TABLE FRIEND(
                                        FIRSTNAME CHAR
(15),
                                        LASTNAME CHAR
(20),
                                        CITY CHAR
(15),
                                        STATE CHAR
(2),
                                        AGE
INTEGER);

Then run gpre as follows
gpre -co -d demo.gdb esql.insert.ecob
This will generate esql.insert.ecob.cbl
edit esql.insert.ecob.cbl
Line 130 Reads as follows
- BY REFERENCE gds__trans, BY VALUE 1
Line 140 Reads as follows
     IF gds__trans NOT = 0 AND gds__0 NOT = 0 THEN
Line 142 Reads as follows
- BY REFERENCE gds__trans, BY VALUE 0
The problem is that gds__trans is not defined anywhere.
I got around this in my Cobol program by adding a
refedine for ISC_TRANS
This problem also need to fixed.

Regards
Andrew Cameron

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alice F. Bird added a comment - 14/Jun/06 09:33 AM
Date: 2002-03-17 21:12
Sender: fsg
Logged In: YES
user_id=70223

I have submitted the fix today.

Pavel Cisar added a comment - 26/Jun/06 10:56 PM
Reopened just to add attachment.

Pavel Cisar added a comment - 26/Jun/06 10:57 PM
Source code to duplicate the problem