Issue Details (XML | Word | Printable)

Key: CORE-2272
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Jiri Cincura
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Server starts returning garbage when killing events connection attempt

Created: 11/Jan/09 11:17 AM   Updated: 12/Nov/09 02:14 PM
Component/s: Engine
Affects Version/s: 2.1.1
Fix Version/s: 2.5 Beta 2, 2.1.3, 2.0.6

Time Tracking:
Not Specified

File Attachments: 1. File CORE-2272.7z (543 kB)
2. Zip Archive test.zip (184 kB)

Environment: FB 2.1.1 SS, Linux 32b NPTL
Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
1. I configured my FB2.1 SuperServer events port to 32768.
2. I've connected to it. So far so good. In response right IP, right port.
3. I've connected again and between port reading and address reading
from response, I've killed the program.
4. From now, I'm getting back weird IPs and weird ports - probably
some numbers from wrong memory location.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Jiri Cincura added a comment - 11/Jan/09 11:19 AM
Run the application:
app.exe "hostname/port:database" "username" "password"

First attempt will be successful (right IP and port), second returns random data.

Alexander Peshkov added a comment - 12/Jan/09 04:57 AM
Can you send me source code for it?
I can't start .Net under wine - it fails in x11 driver.

Jiri Cincura added a comment - 15/Jan/09 04:28 PM
Tweaked sources with test app. are attached.

Alexander Peshkov added a comment - 13/Mar/09 11:05 AM
Jiri, I confirm the issue. But not only port number and IP is bad - the whole event delivery in second attach is broken, I get AVs, assertions, etc. Will investigate more.

Alexander Peshkov added a comment - 17/Apr/09 06:45 AM
Jiri, after fixing http://tracker.firebirdsql.org/browse/CORE-2437 I can't reproduce an issue. Without fixing also could not, but due to getting segfaults :))

Can you check it with HEAD? There were BOFs before fix (and they happened exactly when I tried to connect second time). Therefore I suppose current issue may be also gone now. Though problem may be also due to .Net client (I fixed only fbclient).

I anyway plan to backport 2437 to 2.1 and 2.0, but wish to have your results first.

Jiri Cincura added a comment - 03/May/09 02:57 PM
Hi Alex, looks like it's fixed. I'm not able to reproduce the error now.

Alexander Peshkov added a comment - 22/May/09 01:21 PM
Marked as resolved after fixing related issue.