Issue Details (XML | Word | Printable)

Key: CORE-2291
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Vlad Khorsun
Votes: 0
Watchers: 3
Operations

If you were logged in you would be able to see more operations.
Firebird Core

BUGCHECK 284

Created: 25/Jan/09 11:17 AM   Updated: 11/Mar/11 08:53 AM
Component/s: None
Affects Version/s: 2.5 Alpha 1, 2.1.1, 2.0.5, 2.1.2
Fix Version/s: 2.5 Beta 1, 2.1.3, 2.0.6

Time Tracking:
Issue & Sub-Tasks
Issue Only
Not Specified

Issue Links:
Duplicate
 
Relate
 

Planning Status: Unspecified

Sub-Tasks  All   Open   

 Description  « Hide
recreate table t (id int, f2 char(16));
commit;

insert into t values (1, '0123456798012345');
insert into t values (2, '0123456798012345');
commit;

alter table t drop f2;
commit;

update t set id = 3 where id = 2;
commit;

execute block returns (id int)
as
begin
  select t1.id from t t1 left join t t2 on t1.id = t2.id - 2
   where t2.id = 3
    into :id;
  suspend;
end

Last statement produced bugcheck :

internal Firebird consistency check (cannot restore singleton select data (284), file: rse.cpp line: 3360)


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 25/Jan/09 11:21 AM
Plain SELECT didn't produced bugcheck as problem code executed only when singleton verification is performed by the engine.
Therefore i need PSQL block to reproduce error.

Lukas Petrlik added a comment - 26/Feb/09 12:18 PM
It also happens with 2.0.5 (but not with 2.0.4):

SQL> execute procedure a;
Statement failed, SQLCODE = -902
internal gds software consistency check (cannot restore singleton select data (284), file: rse.cpp line: 3218)

Used software: Firebird 2.0.5 13206-1 Win32 embedded server

Vlad Khorsun added a comment - 06/Mar/09 07:51 AM
Fix is backported into 2.1.3

ramengo added a comment - 03/Apr/09 02:50 AM
Same error here, after upgrading from 2.1.1 to 2.1.2.
Temporary returned to 2.1.1 (where this error doesn't compare) waiting for release of 2.1.3...

Dmitry Yemanov added a comment - 03/Apr/09 02:53 AM
You don't have to wait for v2.1.3, the bugfix is available in recent (post-2.1.2) snapshots.

ramengo added a comment - 03/Apr/09 09:24 AM
Hi Dmitry, thx for the info. But are you sure I can install a snapshot ? Is it stable ? Where to download it ?
Excuse me for too many questions ;-)

Dmitry Yemanov added a comment - 03/Apr/09 10:59 AM

ramengo added a comment - 04/Apr/09 12:35 AM - edited
Excuse my extreme in-experience... I've done this:
- install the Firebird-2.1.2.18118_0_Win32.exe
- download Firebird-2.1.2.18126-0_Win32.7z and extract into C:\Programs\Firebird\Firebird_2_1
- replace the Firebird2Control.cpl in system32 folder
But after restarting the server, at first query received overflow error...
Is this the correct way to install a snapshot ?

maziar added a comment - 07/May/09 07:30 AM
i have same problem in 2.1.2

after one day work of my db in one sp call other sp in return of depth sql same error hapen

Andrew added a comment - 08/Jun/09 08:02 AM
I have such errors:

internal gds software consistency check (cannot restore singleton select data (284), file: rse.cpp line: 3426)

when the following statement is being executed:

select name as file_name, title, text from cms_includes where lower(name) = lower(?)

The installed package is FirebirdSS-2.1.2.18118-0.nptl.i686.rpm.
gfix does not find errors in the database. Doing backup/restore fixes this only for several days.

Alfonso Presa added a comment - 02/Aug/09 02:04 PM
Hi All:

I had the same issue into a trigger but I just change the "select ..." in a "for select xxx" and everythings works fine. Maybe it workaround is usefull for somebody.
I use FIB V2.1.2.18118 on Windows 2003 Server.

Regards,

Al

Rodrigo added a comment - 15/Sep/09 07:09 AM
any fix for 2.0.5?

Pawel added a comment - 20/Sep/09 10:42 PM
Does anybody know reproduce procedure for this issue? Because this occures once on my system and I would like to know how what I have probably done.

Vlad Khorsun added a comment - 20/Sep/09 10:53 PM
Pawel,

re-read my description and suggestion of Alfonso Presa.

But better upgrade to 2.1.3

Pawel added a comment - 21/Sep/09 04:43 PM
I have read it, but unfortunately my knowledge of firebird is not sufficient (e.g. don't understand what "singleton verification" is). Could you please write what is the root cause of this problem, and what kind of action can cause it. Thanks in advance.

Vlad Khorsun added a comment - 21/Sep/09 06:10 PM
Pawel,

does you read what Alfonso Presa suggested ?

Ok, if it is still not clear for you :

code with singleton SELECT :

begin
...
  select ... from ...
    into ...;
...
end

same code without singleton SELECT :

begin
...
  for select ... from ...
    into ...
  do leave;
...
end

Philippe Makowski added a comment - 11/Mar/11 08:53 AM
QA test made