Issue Details (XML | Word | Printable)

Key: CORE-2325
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Attila Molnár
Votes: 1
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

DB created with FB 1.5.x and used with FB 2.x leads to "index page error"

Created: 16/Feb/09 12:08 PM   Updated: 24/Nov/11 06:44 AM
Component/s: None
Affects Version/s: 2.0.4, 2.0.5
Fix Version/s: None


 Description  « Hide
The engine does not throw error, just the queries become very slow (because the index corruption) .The index page error is reported by gfix with -m parameter.

I can reproduce this bug. Unforunetly this means thousands of DDL, DML and DQL sql statements. How can I log all the sql statement?

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 16/Feb/09 12:21 PM
FB 2.x can't corrupt database just because it was created by FB 1.5.x

How could you reproduce corruption ? Do you have some application wich made something with database and it became corrupted ?
Why do yo know it was not already corrupted long time before ?

Attila Molnár added a comment - 16/Feb/09 12:37 PM
I've got the original DB which was created on FB1.5.x (ODS 10.1). The gfix does not report error, and the queries run fine.
After running a subprocess of the application the gfix report the error. I'm using the DB with FB2.0.5.
The subprocess is responsible for the database structure. It compares the actual structure with the desired and makes the neccessary changes if needed (create/alter table/index/storedproc/views/triggers/domains/checks, insert/delete/alter records, etc.)

Vlad Khorsun added a comment - 16/Feb/09 12:49 PM
Could you give to me for analyze
- original (not corrupted) database
- application
- instruction how to reproduce corruption

?

Attila Molnár added a comment - 23/Feb/09 11:39 AM
Hi!

You can download the neccessary files and instructions from the following link :
ftp://firebirdproject:projectfirebird@ftp.mve.hu/testcase.zip

Hope it helps.

Dmitry Yemanov added a comment - 24/Oct/09 04:40 PM
Vlad, was it reproducible? If so, were you able to track the issue down?

Vlad Khorsun added a comment - 24/Oct/09 05:07 PM
Will try it today. I don't remember if i tried it in february ;)

Vlad Khorsun added a comment - 24/Oct/09 10:17 PM
Confirmed.

Looks as a bug in FB 2.x working with ODS 10 databases.
After i upgraded database up to ODS 11 bug is not reproduced anymore.

Tried with current FB 2.0.6

Attila Molnár added a comment - 24/Nov/11 06:44 AM
Hi!

I reviewed my all reports, and I noticed, that this can be related to CORE-2649. (different NULL key encoding by FB 1.5 and FB 2.x for ODS10 and WIN1250)