Issue Details (XML | Word | Printable)

Key: CORE-2331
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Adriano dos Santos Fernandes
Reporter: Mustafa YILMAZ
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

ALTER DOMAIN invalid RDB$FIELD_SUB_TYPE

Created: 18/Feb/09 12:36 PM   Updated: 31/May/11 12:19 PM
Component/s: Engine
Affects Version/s: 2.1.1
Fix Version/s: 2.5 Beta 2

Time Tracking:
Not Specified

Environment:
win2003 x64 Firebird2.1 x64
Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
test case:
CREATE DOMAIN TESTDOM VARCHAR(50);
SELECT RDB$FIELD_SUB_TYPE FROM RDB$FIELDS WHERE RDB$FIELD_NAME = 'TESTDOM';

result 0 OK

ALTER DOMAIN TESTDOM TYPE VARCHAR(80);
SELECT RDB$FIELD_SUB_TYPE FROM RDB$FIELDS WHERE RDB$FIELD_NAME = 'TESTDOM';

result 311 (or random ?)




 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Adriano dos Santos Fernandes added a comment - 18/Feb/09 12:56 PM
I can't reproduce in Win32.

Gabor Boros added a comment - 18/Feb/09 01:13 PM
CREATE DOMAIN TESTDOM VARCHAR(50);
COMMIT;
ALTER DOMAIN TESTDOM TYPE VARCHAR(80);
COMMIT;

Then SELECT RDB$FIELD_SUB_TYPE FROM RDB$FIELDS WHERE RDB$FIELD_NAME = 'TESTDOM';

The result is 4 for me with 2.1.2 RC1 SS on Win32.

Pavel Cisar added a comment - 31/May/11 12:19 PM
QA test added.