Issue Details (XML | Word | Printable)

Key: CORE-2397
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Vlad Khorsun
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

If you drop two different indexes within the same transaction, you get database corruption

Created: 30/Mar/09 03:15 AM   Updated: 11/Mar/11 12:56 PM
Component/s: Engine
Affects Version/s: 2.1.0, 2.5 Alpha 1, 2.1.1, 2.1.2, 2.5 Beta 1
Fix Version/s: 2.5 Beta 2, 2.1.3

Time Tracking:
Not Specified

Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
Test case by Steve Summers :

create table test(id int, title varchar(50));

commit;

create index test1 on test computed by (id +1);

commit; // There is not an issue creating two computed indexes in the same transaction, so this commit is optional.

create index test2 on test computed by (id +2);

commit;

drop index test1;

// If you add a commit here, everything is fine.

drop index test2;

commit;

insert into test values(1,'test'); -- Error, file handle is invalid.



 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Joel da Rosa added a comment - 31/Mar/09 05:40 AM
my test not find problems.

use a example in tracker with: windows xp sp2, firebird 2.1.1 - ibexpert.

and now?

Vlad Khorsun added a comment - 31/Mar/09 01:45 PM
FB 2.1.1 give me :

Unsuccessful execution caused by a system error that precludes successful execution of subsequent statements.
internal Firebird consistency check (invalid SEND request (167), file: exe.cpp line: 643).

Philippe Makowski added a comment - 11/Mar/11 12:56 PM
QA test made