Issue Details (XML | Word | Printable)

Key: CORE-2441
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: freemanzav
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Server crashes on UPDATE OR INSERT statement

Created: 27/Apr/09 03:58 PM   Updated: 31/May/11 04:19 PM
Component/s: Engine
Affects Version/s: 2.1.0, 2.1.1, 2.1.2
Fix Version/s: 2.5 Beta 2, 2.1.3

Time Tracking:
Not Specified

Environment: CS
Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
Server Firebird 2.1 CS, OS win xp

CREATE TABLE TABLE_TXT (
    FIELD1 VARCHAR(255)
);

Query:
UPDATE OR INSERT INTO TABLE_TXT (FIELD1)
VALUES (CAST(:FIELD1 AS TIMESTAMP))
MATCHING(FIELD1);

Error:
Unsuccessful execution caused by a system error that precludes
successful execution of subsequent statements.
Error writing data to the connection.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 27/Apr/09 05:28 PM
confirmed on linux HEAD

Pavel Cisar added a comment - 31/May/11 04:19 PM
QA test added.