Issue Details (XML | Word | Printable)

Key: CORE-2602
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Adriano dos Santos Fernandes
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Attachments using NONE charset may cause reads from MON$ tables to fail

Created: 27/Aug/09 07:21 AM   Updated: 26/Apr/13 09:12 AM
Component/s: Charsets/Collation, Engine
Affects Version/s: 2.5 Alpha 1, 2.5 Beta 1, 2.5 Beta 2, 2.1.3
Fix Version/s: 2.5 RC1

Time Tracking:
Not Specified

Issue Links:
Relate

Planning Status: Unspecified


 Description  « Hide
When an attachment using NONE charset uses non-ASCII characters that go to MON$ tables, selects from MON$ tables (in other attachments) fail.

The error is about incorrect transliteration (v2.1.X) or malformed string (v2.5).

The problem is that with NONE there is no way to convert strings from unknown charset to system charset, that will be converted later to client charset.

The solution for this problem is to replace (only with attachments using NONE) non-ASCII characters that go to MON$ to question marks.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 26/Apr/13 09:12 AM
Test added.