Issue Details (XML | Word | Printable)

Key: CORE-2607
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Adriano dos Santos Fernandes
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Introducer (_charset) problems with monitoring and persistent modules

Created: 29/Aug/09 05:28 PM   Updated: 26/Apr/13 08:17 AM
Component/s: Charsets/Collation, Engine
Affects Version/s: 2.1.0, 2.5 Alpha 1, 2.1.1, 2.1.2, 2.5 Beta 1, 2.5 Beta 2
Fix Version/s: 2.5 RC1

Time Tracking:
Not Specified

Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
Usage of introducer (_charset ) is problematic due to usage of different character sets in a single command. The problems are different from version to version, and may be transliteration error, malformed string or just unexpected things.

It happens in two different usage scenarios.
1) When a query use it, and another selects from MON$STATEMENTS.
2) When it's used in a persistent module (SP, trigger).

The solution for the problem is to transform the introducer strings to a form capable to be represented in ASCII characters.

So, for example, this command:
    select _dos850 '123áé456' from rdb$database
May be transformed to:
    select _dos850 X'313233A082343536' from rdb$database

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Pavel Cisar added a comment - 26/Apr/13 08:17 AM
Test added.