Issue Details (XML | Word | Printable)

Key: CORE-2693
Type: Bug Bug
Status: Open Open
Priority: Major Major
Assignee: Unassigned
Reporter: Kim Pedersen
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

"semget failed" using gfix or gbak

Created: 18/Oct/09 07:06 PM   Updated: 13/Dec/11 08:20 AM
Component/s: Engine, GBAK, GFIX
Affects Version/s: 2.1.1, 2.1.2, 2.1.3
Fix Version/s: None

Environment: Firebird CS 2.1.3 running linux, Fedora 6, Fedora 12


 Description  « Hide
I have about 40 servers running Firebird CS 2.1.3 on Fedora Core 6. The system is running fine all day long but in the evening a shell script is being run automatically. It performs some tasks on the database, but now and then the Firebird tools crash with the error "cannot attach to password database" and in firebird.log the following messages appear:

operating system directive semget failed
No such file or directory

Here's the list of tasks performed on the database:

- Switch to single user mode: gfix -shut single -force 0 hostname:/db/database.fdb
- Make raw copy of database with cp command
- Backup database: gbak -b -z -v hostname:/db/database.fdb /db/database.fbk -Y logfile.txt
- Validate database: gfix -validate -full hostname:/db/database.fdb
- Restore database: gbak -c -z -v -p 4096 /db/database.fbk /db/newdb.fdb -Y logfile.txt

Most days no problems occurs at all, but sometimes one of the installations will crash when gfix or gbak (at random) is being run.
Before upgrading to 2.1.3 we were running 2.0.1 without any problems, so something related to our problem must have changed.

I have tried to change the kernel.sem in /etc/sysctl.conf from

default: 250 32000 32 128
to: 250 32000 100 128

but without any luck.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Philippe Makowski added a comment - 24/May/11 07:45 PM
Kim, is your issue solved ?
is it still valid for Firebird 2.1.4
how did you setup Firebird ? from project tar.gz ?
Did you upgrade your Fedora ?
or can we close this bug ?

 

Kim Pedersen added a comment - 25/May/11 07:13 AM
The issue hasn't been resolved. We are now running Fedora 12 and it is the same problem. We installed Firebird using the RPM FirebirdCS-2.1.3.18185-0.i686.rpm.

I will be back from holidays in 2 weeks and then I will upgrade to Firebird 2.1.4 or Firebird 2.5.0. When the new Firebird has been run for about 1 month I can get a pretty good picture showing if the issue has been resolved or not. The error occurs 2-5 times per month in some our 36 installation sites.
I will report back to tell you if it has been fixed or not.

Kim Pedersen added a comment - 13/Dec/11 08:20 AM
After upgrading to FirebirdCS 2.5.1 the problem hasn't occured anymore. The servers has been running for 2 month now, so I suppose this issue can be closed.