Issue Details (XML | Word | Printable)

Key: CORE-2728
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Daniel
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Access Violation when trying to add an user that already exists

Created: 02/Nov/09 11:23 PM   Updated: 10/Mar/11 05:11 AM
Component/s: GSEC
Affects Version/s: 2.1.3
Fix Version/s: 2.5 RC2

File Attachments: None
Image Attachments:

1. screenshot-1.jpg
(75 kB)

2. screenshot-2.jpg
(45 kB)
Environment:
intel Pentium 4, 2.80 GHz
1Gb RAM
Windows 2000 sp4


 Description  « Hide
GSEC gives an Access Violation when trying to add an user that already exists, instead of an DBKey violation.

This doesn't happen with 1.5 version.

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 29/Nov/09 02:14 PM
Damiel, your bugreport was definitely useful - I've found problems in 2.5 and 3.0. But what about 2.1 - failed to reproduce. Please describe better what did you do to have AV.

Alexander Peshkov added a comment - 14/Jan/10 10:55 AM
Daniel commented on CORE-2728:
------------------------------

Open windows command prompt and type this:

CD\
CD Archivos de Programa\FireBird\Firebird_2_1\bin
SET ISC_USER=SYSDBA
SET ISC_PASSWORD=masterkey
GSEC
ADD DANIEL -PW DANIEL -> it works at first time
ADD DANIEL -PW DANIEL -> Second time, gives an Access violation

Alexander Peshkov added a comment - 14/Jan/10 10:57 AM
Daniel, just to make sure - do you have correct fbclient in your path?

Alexander Peshkov added a comment - 03/Feb/10 12:07 PM
No response from author, could not reproduce in mentioned version 2.1 - therefore closing.
Marked as 'Fixed' cause was reproduced in 2.5 and 3.0.

Daniel added a comment - 05/Feb/10 12:47 PM
I tried many times last few weeks to attach the screenshot, but I was unable to login FireBird Tracker.

See the screenshot.

Alexander Peshkov added a comment - 05/Feb/10 01:08 PM
Daniel, I see you do have this bug. But I've asked not about gsec versions, but about fbclient version. The simplest way to make sure is use isql (from same place where gsec faults):

# ./isql -user sysdba -pas masterkey -z localhost:employee

Output will be:

ISQL Version: LI-V2.0.5.13206 Firebird 2.0
Server version:
LI-T3.0.0.27582 Firebird 3.0 Unstable
LI-T3.0.0.27582 Firebird 3.0 Unstable/tcp (fbs2)/P10
LI-V2.0.5.13206 Firebird 2.0/tcp (fbs2)/P10
Database: localhost:employee, User: sysdba

If fbclient is OK, the only remaining thing is to ask you to provide remote access to the box where it's reproducible - none of developers were able to reproduce the bug.

Alexander Peshkov added a comment - 05/Feb/10 04:58 PM
Daniel, can you try 2.1 snapshot build?

Anderson Farias added a comment - 28/Jan/11 02:01 AM
Could not reproduce with FB 2.1.3, SS, 32bits on Windows 7 64

gsec version WI-V2.1.3.18185 Firebird 2.1

GSEC> add USER_NAME -pw 123456
An error occurred while attempting to add the user.
violation of PRIMARY or UNIQUE KEY constraint "INTEG_2" on table "RDB$USERS"

ISQL Version: WI-V2.1.3.18185 Firebird 2.1
Server version:
WI-V2.1.3.18185 Firebird 2.1
WI-V2.1.3.18185 Firebird 2.1/tcp (Primus)/P11
WI-V2.1.3.18185 Firebird 2.1/tcp (Primus)/P11

regards,