Issue Details (XML | Word | Printable)

Key: CORE-2756
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alex Bekhtin
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

substring from timestamp - unexpected result

Created: 17/Nov/09 07:15 PM   Updated: 28/May/15 04:52 PM
Component/s: Engine
Affects Version/s: 2.5 Beta 2, 3.0 Initial, 2.5 RC1, 2.5.0
Fix Version/s: 2.5 RC3, 2.5.1, 3.0 Alpha 1

Environment:
Firebird-2.5.0.25784-0_Win32
XP SP2, Win7, Linux

QA Status: Done successfully
Test Details:
Test uses SIMILAR TO in order to check format of output.
If it will fail in the future than it can be due to some bugs in SIMILAR TO algorithm.
See CORE-2006 and list of tickets related to SIMILAR TO there.


 Description  « Hide
FB 2.1
select current_timestamp || '' from rdb$database
2009-11-17 10:55:26.3770

select substring(current_timestamp from 1 for 25) from rdb$database
2009-11-17 10:55:50.5010

FB 2.5
select current_timestamp || '' from rdb$database
2009-11-17 10:56:22.8760

select substring(current_timestamp from 1 for 25) from rdb$database
17-NOV-2009 10:56:41.0790 -- NOV (!)

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Adriano dos Santos Fernandes added a comment - 11/Mar/10 01:57 AM
This seems to be already fixed by Alex in a commit that fixed other thing.

Milan Babuskov added a comment - 04/Dec/10 07:47 PM
I can confirm that bug still exists in final 2.5 release: LI-V2.5.0.26074 Firebird 2.5

Sean Leyne added a comment - 04/Dec/10 08:41 PM
Re-opened at Milan's request

Brenden Walker added a comment - 27/Dec/10 07:19 PM
This appears to be fixed (for me) in Windows 7 64 bit running FB 2.5.0 26074, 32-bit.

SQL> select current_timestamp || '' from rdb$database;

CONCATENATION
=========================
2010-12-27 14:17:32.6770

SQL> select substring(current_timestamp from 1 for 25) from rdb$database;

SUBSTRING
=========================
27-DEC-2010 14:17:44.5470


Anderson Freitas Alves added a comment - 31/Dec/10 04:54 PM
Error not found in:

- LI-V2.5.0.26076 Firebird 2.5 SuperClassic
- LI-V2.5.1.26160 Firebird 2.5 SuperClassic

Tested in server CentOS Linux 5.5 64 bits, with FlameRobin 0.9.3.2077 Unicode running in Windows XP.

Dmitry Yemanov added a comment - 11/Jan/11 04:05 PM
Alex, could you please re-test whether the issue really exists in v2.5.0 26074 and, if so, whether it had disappeared in the subsequent builds?

Alexander Peshkov added a comment - 12/Jan/11 07:54 AM
Dmitry, it see it reproduced in both 2.5.0 26074 & 2.5.1.26166, i.e. it has not disappeared. What is our release schedule for 2.5.1?

Dmitry Yemanov added a comment - 12/Jan/11 08:44 AM
February, I guess. So we still have some time for bug fixing.

Alexander Peshkov added a comment - 17/Jan/11 05:48 PM
Issue was noticed by Claudio in HEAD a year ago and fixed by me without ticket on the tracker - it seemed that this is head-specific thing. Now I've backported this fix to 2.5, i.e. everything should be OK in 2.5.1.