Issue Details (XML | Word | Printable)

Key: CORE-2807
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Problem with tracing on Linux

Created: 14/Jan/10 09:04 AM   Updated: 14/Feb/11 11:59 AM
Component/s: Engine
Affects Version/s: 3.0 Initial, 2.5 RC1
Fix Version/s: 2.5 RC2, 3.0 Alpha 1

Environment: posix


 Description  « Hide
Reported in devel by Milan Babuskov.

Trace, started embedded, prevents remote attachments to SC server. With fbtrace.conf:
<database>
   enabled true
   log_statement_prepare true
   log_statement_free true
   log_statement_start true
   log_statement_finish true
   time_threshold 0
</database>
as root:

root@milanb:/# /opt/firebird/bin/fbsvcmgr service_mgr
action_trace_start trc_name "My trace" trc_cfg ./fbtrace.conf

makes it impossible to attach to server:
------------------------------------------
SQL Message : -902
Unsuccessful execution caused by a system error that precludes
successful execution of subsequent statements

Engine Code : 335544373
Engine Message :
operating system directive write failed
Bad file descriptor
------------------------------------------

When tracing is not running, everything works fine.


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 14/Jan/10 09:08 AM
Use generic openCreate for trace data files.