Issue Details (XML | Word | Printable)

Key: CORE-2861
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: Jiri Cincura
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Cannot remove user with dot in login

Created: 12/Feb/10 04:07 PM   Updated: 10/Jan/16 06:48 PM
Component/s: API / Client Library, GSEC
Affects Version/s: 2.5 RC2
Fix Version/s: 2.5 RC3, 3.0 Alpha 1

Environment: 2.5RC2 32b SC, Slackware Linux
Issue Links:
Duplicate
 

QA Status: Done successfully
Test Details:
Since 10.01.2016 this test (for 3.0) is based on totally new algorithm with checking ability of
normal work with randomly generated logins. These logins consists only of punctuation chars and
for sure will have at least one dot.
The reason of this replacement was failed results on Classic 3.0 when 'gsec' utility is invoked.
Code for 2.5 was not changed and is preserved (though it was missed for 2.5 before, but it works OK).

See http://web.firebirdsql.org/download/prerelease/results/archive/ for builds: 3.0.0.32266 3.0.0.32268

Correctness of current code was verified by batch scenario, totally about ~1500 iterations was done.
Several samples of logins that were be checked:
    ,(/;.>_:%$^`.&<|#?=[~\*}-{@)
    >=[{+%\.&|~$`(;#._,])}?*@:^!
    }^\*@.)#>|/;&!=~`]<[,?.-:(%.

NOTE: currently we EXCLUDE single and double quotes from random login because of CORE-5072.

This login is handled then by both FBSVCMGR and ISQL utilities:
1) run FBSVCMGR and:
  1.1) add user
  1.2) modifying some of its attributes (password, firstname etc).
  NOTE! We do *not* run 'fbsvcmgr action_delete_user' because it does not work (at least on build 32268)
  COMMAND:
    fbsvcmgr localhost/3333:service_mgr user sysdba password masterkey ^
        action_delete_user dbname C:\MIX\firebird\fb30\security3.fdb ^
        sec_username john
  STDERR: unexpected item in service parameter block, expected isc_spb_sec_username
  (sent letter to Alex, 09-jan-2016 22:34; after getting reply about this issue test can be further changed).
2) run ISQL and:
  2.1) drop this user that could not be dropped in FBSVCMGR - see previous section.
  2.2) create this login again;
  2.3) modifying some of this login attributes;
  2.4) drop it finally.


 Description  « Hide
When I try to delete user with dot in login via services API or gsec I get error:
./gsec -delete 'foo.bar'
An error occurred while attempting to delete the user record.
Dynamic SQL Error
SQL error code = -104
Token unknown - line 1, column 29
.


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 17/May/10 10:43 AM
Bug (though looking a but differently) is caused by exactly same reason - missing quotes in SQL statement generated by gsec.

Alexander Peshkov added a comment - 17/May/10 10:44 AM
already fixed dup issue 3000