Issue Details (XML | Word | Printable)

Key: CORE-2968
Type: Bug Bug
Status: Closed Closed
Resolution: Won't Fix
Priority: Critical Critical
Assignee: Unassigned
Reporter: Pavel Jaoshvili
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Firebird crashes on MacOSX

Created: 16/Apr/10 05:38 AM   Updated: 20/Apr/10 08:07 AM
Component/s: API / Client Library
Affects Version/s: 2.1.3
Fix Version/s: None

Time Tracking:
Not Specified

Environment: MacOSX 10.5 or MacOSX 10.6

Planning Status: Unspecified


 Description  « Hide
Firebird crashes at ThreadData::restoreSpecific ().
I think it similar to http://tracker.firebirdsql.org/browse/CORE-2961
Could you rebuild package to fix this issue?

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Paul Beach added a comment - 16/Apr/10 07:19 AM
Classic or SuperServer? Intel or PowerPC? 32bit or 64bit? Any more information about the crash?

Pavel Jaoshvili added a comment - 16/Apr/10 09:55 AM
Crash log

Thread 14 Crashed:
0 com.firebirdsql.Firebird 0x30025502 (anonymous namespace)::YEntry::~YEntry() + 50
1 com.firebirdsql.Firebird 0x300305b5 isc_detach_database + 229
2 ru.motiw.XConductor 0x000620b3 ibpp_internals::DatabaseImpl::Disconnect() + 77
3 ru.motiw.XConductor 0x00059f3c CFirebirdDatabase::~CFirebirdDatabase() + 160
4 ru.motiw.XConductor 0x0002943c CDataHandler::run() + 1816
5 libPocoFoundation.8.dylib 0x00c4945e Poco::ThreadImpl::runnableEntry(void*) + 122
6 libSystem.B.dylib 0x90ac8a19 _pthread_start + 345
7 libSystem.B.dylib 0x90ac889e thread_start + 34

This can be reproduced on both Classic and SuperServer, 32 and 64 bit on Intel

Pavel Jaoshvili added a comment - 16/Apr/10 09:56 AM
And another crash log

Thread 7 Crashed:
0 com.firebirdsql.Firebird 0x30025502 (anonymous namespace)::YEntry::~YEntry() + 50
1 com.firebirdsql.Firebird 0x3002936a isc_dsql_fetch_m + 282
2 com.firebirdsql.Firebird 0x30029638 isc_dsql_fetch + 360
3 ru.motiw.XConductor 0x0007b48b ibpp_internals::StatementImpl::Fetch() + 217
4 ru.motiw.XConductor 0x000512e8 CFirebirdStatement::Fetch() + 20
5 ru.motiw.XConductor 0x0001b01c CCounter::Synchronize(IDatabase*) + 378
6 ru.motiw.XConductor 0x00026721 CDataHandler::switchFlag(int) + 313
7 ru.motiw.XConductor 0x00028daa CDataHandler::run() + 134
8 ru.motiw.XConductor 0x0008067c CMessageQueueDispatcher::run() + 78
9 libPocoFoundation.8.dylib 0x00c4945e Poco::ThreadImpl::runnableEntry(void*) + 122
10 libSystem.B.dylib 0x90ac8a19 _pthread_start + 345
11 libSystem.B.dylib 0x90ac889e thread_start + 34

Paul Beach added a comment - 16/Apr/10 10:03 AM
Do you have an example so we can reproduce the problem?

Pavel Jaoshvili added a comment - 16/Apr/10 12:59 PM
I can not give you example because this is commercial application :(
But I think this error occurs because application utilizes multithreaded database access approach.

Pavel Jaoshvili added a comment - 16/Apr/10 12:59 PM
I cann't reproduce it on a signle thread.

Dmitry Yemanov added a comment - 16/Apr/10 03:13 PM
Firebird client/embedded library is not thread safe prior to FB v2.5, so you should explicitly synchronize Firebird API calls at the application level.

It's worth testing your application with fbclient/fbembed from FB v2.5. If the problem doesn't occur, then we probably know the reason. But it's not going to be fixed in older versions, use FB 2.5 instead.

Pavel Jaoshvili added a comment - 19/Apr/10 06:02 AM
Yeah, Firebird v2.5 works well.
This issue may be closed. Thanks a lot.