Issue Details (XML | Word | Printable)

Key: CORE-2993
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Dmitry Yemanov
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Fatal lock manager error "Invalid lock id (NNN)" while working with monitoring tables on a highly loaded system

Created: 06/May/10 07:07 AM   Updated: 14/Feb/11 10:18 AM
Component/s: Engine
Affects Version/s: 2.1.0, 2.1.1, 2.1.2, 2.1.3, 3.0 Initial, 2.5 RC1, 2.5 RC2
Fix Version/s: 2.5 RC3, 2.1.4, 3.0 Alpha 1

Time Tracking:
Not Specified

File Attachments: 1. File core-2993.exe.7z (273 kB)
2. File core-2993.src.7z (2 kB)

Environment: Classic, SuperClassic
Issue Links:
Duplicate
 

Planning Status: Unspecified


 Description  « Hide
Server crash or freeze are possible as after-effects, and possibly index corruptions as well. It's reproducible easier with v2.5 than with v2.1.

This issue is caused by some logic errors in synchronization related to the monitoring activities. It may occur under quite rare condition when the lock requester gets its AST delivered while it's still waiting inside the lock manager (lock is granted but the thread still cannot check-in back into the engine) and it happens twice subsequently.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 06/May/10 12:06 PM
Test case sources, plain Delphi 6 was used.

Vlad Khorsun added a comment - 06/May/10 12:06 PM
Test case. Compiled exe.