Issue Details (XML | Word | Printable)

Key: CORE-2995
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Same error in status vector reported twice

Created: 07/May/10 09:06 AM   Updated: 04/Feb/11 12:05 PM
Component/s: API / Client Library
Affects Version/s: 2.1.3, 2.5 RC2
Fix Version/s: 2.5 RC3, 2.1.4, 3.0 Alpha 1

Time Tracking:
Not Specified

File Attachments: 1. File dsql_sql_info.cpp (2 kB)


Planning Status: Unspecified


 Description  « Hide
This bug was initially noticed by GLDS using IBO componnets an then reproduced by me using pure API. Attached test program must output:

conversion error from string "--2"
Dynamic SQL Error
-SQL error code = -104
-Token unknown - line 1, column 9
-*
Dynamic SQL Error
-SQL error code = -104
-Token unknown - line 1, column 9
-*
conversion error from string "--2"
Second OK

Though correct one must be:

conversion error from string "--2"
Dynamic SQL Error
-SQL error code = -104
-Token unknown - line 1, column 9
-*
Dynamic SQL Error
-SQL error code = -104
-Token unknown - line 1, column 9
-*
First OK
Second OK


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 07/May/10 09:07 AM
test program

Vlad Khorsun added a comment - 07/May/10 01:03 PM
I didn't verified but sooner of all bug was present since v 2.1.0