Issue Details (XML | Word | Printable)

Key: CORE-3089
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Vlad Khorsun
Reporter: Andrey Feklistov
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Attempt of execute statement on external datasource failed when datasource is interbase 4.1

Created: 29/Jul/10 11:13 PM   Updated: 14/Feb/11 12:04 PM
Component/s: Engine
Affects Version/s: 2.5 RC2
Fix Version/s: 2.5.0, 3.0 Alpha 1

Time Tracking:
Not Specified

Planning Status: Unspecified


 Description  « Hide
Executing procedure

create or alter procedure TEST1
returns (
V_INT integer)
as
begin
for execute statement 'select 1+1 from rdb$database'
on external '________'
with common transaction
as user 'SYSDBA' password 'masterke'
into :v_int do
suspend;
end

with target database of interbase 4.1 results in
"Unsuccessful execution caused by system error that does not preclude successful execution of subsequent statements.
Unexpected error in isc_database_info.
At procedure 'TEST1' line: 6, col: 3." message.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Sean Leyne added a comment - 30/Jul/10 04:05 PM
Are you serious???!!!!

You expect Firebird to support connectivity to a Interbase **4.1** database!

Andrey Feklistov added a comment - 03/Aug/10 08:20 AM
Actually, YES.

1. As fbclient.dll fully compatible with IB4.1 and other old versions, cost of this fix should be rather low.
2. Using FB2.5 to simply aggregate or consolidate data from old databases and develop new functionality in new environment supporting integrity and one entry point in information system - great argument to use Firebird by users of some ancient or proprietary software.

Sean Leyne added a comment - 03/Aug/10 05:37 PM
1 - It is poor thinking to assume that because an application can use the FBClient to connect to a IB 4.1 database, that the external database access functionality would support the same.

2 - I could argue that you should be able easily to use Firebird with the ancient/proprietary software by simply migrating the existing database to a newer Firebird database structure.

Vlad Khorsun added a comment - 06/Aug/10 03:25 PM
The issue is that pre-IB6 engines don't understand isc_info_db_sql_dialect as there was no SQL dialects before IB6.
I see no problem to fix it.
Fix is committed, please confirm it (using tomorrows snapshot build)