Issue Details (XML | Word | Printable)

Key: CORE-3139
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Unassigned
Reporter: James
Votes: 0
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Firebird gsec problem under Windows 7

Created: 18/Sep/10 10:16 AM   Updated: 22/Sep/10 03:06 PM
Component/s: GSEC
Affects Version/s: 2.1.1
Fix Version/s: None

Environment: Windows 7 Home


 Description  « Hide
Hi,

After I installed Firebird under Windows 7, I can not execute "gsec". Even "gsec ?" will me errors like:
(I double checked that Firebird service is running)

D:\>gsec
Cannot attach to services manager
user name and password are required while attaching to the services manager
unable to open database

D:\>gsec ?

   gsec utility - maintains user password database
........

   available parameters:
     -pw <password>
     -uid <uid>
     -gid <uid>
     -fname <firstname>
     -mname <middlename>
     -lname <lastname>

Cannot attach to services manager
user name and password are required while attaching to the services manager
unable to open database



D:\>gsec -user sysdba -pass masterkey
Your user name and password are not defined. Ask your database administrator to
set up a Firebird login.
unable to open database


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Paul Reeves added a comment - 22/Sep/10 12:32 PM
I did a fresh install of 2.1.1 on a clean install of W7.

I cannot reproduce this problem. In fact, gsec works for me as a normal user. I don't even need to run as admin.

I suspect the cause of the problem lies elsewhere. Perhaps the sysdba password is not masterkey?