Issue Details (XML | Word | Printable)

Key: CORE-316
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Adriano dos Santos Fernandes
Reporter: Adriano dos Santos Fernandes
Votes: 1
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Can't open database with MBCS/Extended characters in name

Created: 25/Aug/04 12:00 AM   Updated: 22/Jun/12 08:28 PM
Component/s: Engine
Affects Version/s: None
Fix Version/s: 2.5 Beta 1

Time Tracking:
Not Specified

Issue Links:
Duplicate
 

SF_ID: 1015925


 Description  « Hide
SFID: 1015925#
Submitted By: asfernandes

Extended characters in filenames isn't converted from
connection charset to OS code page.

This causes wrong filenames when creating databases
with a charset different from the OS code page.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alice F. Bird added a comment - 14/Jun/06 09:38 AM
Date: 2005-10-05 02:02
Sender: seanleyne
Logged In: YES
user_id=71163

Dmitry,

Yes, the 2 issues are the same.

Although #839060 was opened first, I would suggest that it
be closed as "duplicate" since this item since to better
describe the problem.

Alice F. Bird added a comment - 14/Jun/06 09:38 AM
Date: 2005-10-03 21:12
Sender: dimitr
Logged In: YES
user_id=61270

BTW, is SF #839060 related to this issue?

Alice F. Bird added a comment - 14/Jun/06 09:38 AM
Date: 2005-04-15 15:38
Sender: asfernandes
Logged In: YES
user_id=940451

While with the new INTL architecture this bug can be fixed,
there is one big problem yet.

How to maintain compatibility with pre-ODS11 databases and
backups?

Many system tables store filenames with charset NONE.

To fix this bug the fields that store filenames should be
changed to charset UNICODE_FSS.

Then the server can convert between the client charset and
UNICODE_FSS and between UNICODE_FSS and the system code page.

Alice F. Bird added a comment - 14/Jun/06 09:38 AM
Date: 2005-04-15 07:16
Sender: percyboy
Logged In: YES
user_id=908241

Can you tell me:
Do you have a plan to solve this bug?
Would it be included in the next release?

Thanks!

I am planning to use Firebird but met the bug
stopping my work.(as described in bug # 1182700)

Alice F. Bird added a comment - 14/Jun/06 09:38 AM
Date: 2005-04-14 17:24
Sender: seanleyne
Logged In: YES
user_id=71163

To further elaborate, based on comments noted in tracker #
1182700, the problem is not limited to the filename itself but
the full path\filename string.

Alice F. Bird added a comment - 14/Jun/06 09:38 AM
Date: 2004-11-14 22:43
Sender: seanleyne
Logged In: YES
user_id=71163

Updating the description/summary to better reflect the true
nature of the bug.

Henri Gourvest added a comment - 03/Dec/08 11:17 AM
I think the aliases.conf file is also concerned by this issue.