Issue Details (XML | Word | Printable)

Key: CORE-3175
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: Major Major
Assignee: Paul Beach
Reporter: haydie rodriguez
Votes: 0
Watchers: 1

If you were logged in you would be able to see more operations.
Firebird Core

"error reading data from connection" before the gbak restore ends.

Created: 11/Oct/10 06:15 AM   Updated: 25/May/11 09:45 AM
Component/s: None
Affects Version/s: 2.5.0
Fix Version/s: None

Environment: OSX Snow Leopard (10.6) - Server Version, Xserve hardware, 6GB Ram, Firebird Database file size is 3GB. Using the 64-bit 2.5.0 Release version of Firebird (latest)

 Description  « Hide
backup works fine in OS X Snow Leopard but when restoring using gbak, an error message "error reading data from connection" appears at the end of the restore process. Tested on 3 Xserves and got the same result. I don't encounter the problem on ver 2.1, 2.0 and 1.5 on the same servers.

I tried in Windows and Linux and did not encounter such problem.

below is the last portion of gbak from OS X Terminal:

gbak: activating and creating deferred index LOOKUPOPCODESUNQ2
gbak: activating and creating deferred index LOOKUPREJTYPESUNQ
gbak: activating and creating deferred index LOOKUPREJTYPESUNQ2
gbak: committing metadata
gbak: ERROR:Error reading data from the connection.
gbak:Exiting before completion due to errors
gbak: ERROR:Error reading data from the connection.

I tried doing the same with other databases and also getting the same error.

The database seems to be created even with the errors. However, gstat shows the ff:

Attributes single-user maintenance

This is ok since I can still use gfix to put the database in multi-user mode. However, I am not sure if the database is created completely and without any error. Because of this doubt, I cannot bring the database in production mode

 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
There are no subversion log entries for this issue yet.