Issue Details (XML | Word | Printable)

Key: CORE-3203
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Critical Critical
Assignee: Dmitry Yemanov
Reporter: Rodrigo Coelho
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

UPDATE OR INSERT with RETURNING causes "Invalid Cursor" error

Created: 28/Oct/10 03:15 PM   Updated: 04/Feb/11 01:13 PM
Component/s: None
Affects Version/s: 2.5.0
Fix Version/s: 2.5.1

Time Tracking:
Not Specified

File Attachments: 1. File UpdateOrInsert.rar (752 kB)

Environment:
OS: Windows 7
App: Delphi 2010.
Firebird 2.5 SuperClassic
Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
When I execute the UPDATE OR INSERT command with RETURNING occurs a "Invalid Cursor" error

Sometimes the command is not execute successfully.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 28/Oct/10 03:30 PM
What is the *exact* error message returned by the server?

Rodrigo Coelho added a comment - 28/Oct/10 05:22 PM
"Invalid Cursor reference
Cursor is not open."

This error is show on Delphi application.

I attached a sample demonstrating it.

Steps to reproduce:

1 - Type an ID and Name;
2 - Click on "It not works";
3 - Click on "It works"

Sincerely,
Rodrigo.

Dmitry Yemanov added a comment - 31/Oct/10 08:50 AM
Please try the next snapshot build (to appear in a couple of days) and report back. It should be fixed there.

Rodrigo Coelho added a comment - 03/Nov/10 10:59 AM
OK, the problem was fixed

Thanks,
Rodrigo.