Issue Details (XML | Word | Printable)

Key: CORE-3212
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Efremov Aleksandr Valer'evich
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Error compile 2.5 for FreeBSD

Created: 02/Nov/10 11:30 AM   Updated: 04/Feb/11 01:15 PM
Component/s: None
Affects Version/s: 2.5.0
Fix Version/s: 2.5.1, 3.0 Alpha 1

Time Tracking:
Not Specified

File Attachments: 1. Text File 3212.patch (0.6 kB)

Environment: FreeBSD 8.1-STABLE

Planning Status: Unspecified


 Description  « Hide
If we compile fresh 2.5, we get

gmake -f ../gen/Makefile.embed.util ../gen/firebird/bin/create_db
gmake[3]: Entering directory `/home/user/firebird/firebird2.5/firebird2/gen'
gmake[3]: `../gen/firebird/bin/create_db' is up to date.
gmake[3]: Leaving directory `/home/user/firebird/firebird2.5/firebird2/gen'
rm -f empty.fdb
../gen/firebird/bin/create_db empty.fdb
Fatal lock manager error: mutex init failed, errno: 2
--No such file or directory
gmake[2]: *** [empty.fdb] Segmentation fault: 11 (core dumped)
gmake[2]: *** Deleting file `empty.fdb'
gmake[2]: Leaving directory `/home/user/firebird/firebird2.5/firebird2/gen'
gmake[1]: *** [empty_db] Error 2
gmake[1]: Leaving directory `/home/user/firebird/firebird2.5/firebird2/gen'
gmake: *** [firebird] Error 2

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 02/Nov/10 01:43 PM
What happens if we compile as root and later try to run as non-root - does it start or not?

Efremov Aleksandr Valer'evich added a comment - 03/Nov/10 06:03 AM
This error occurs in the course of compilation and doesn't depend under whom to compile

Alexander Peshkov added a comment - 11/Nov/10 01:48 PM
The problem is very low default limit of SYSV semaphores on freebsd. You should better increase that value (existing 60 may be anyway not enough for firebird to run under high load). But to let us compile and run on out-of-the-box OS you may apply 3212.patch (very simple one).

Alexander Peshkov added a comment - 11/Nov/10 01:59 PM
FreeBSD 8.1 has abnormally (for year 2010) small limit of available SysV semaphores == 60. This may be enough to work under small load, therefore learn firebird to work with so small limit allocating semaphores in smaller sets.

Efremov Aleksandr Valer'evich added a comment - 12/Nov/10 07:15 AM
Thanks, all work. Firebird the best!!!