Issue Details (XML | Word | Printable)

Key: CORE-3220
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Minor Minor
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

isc_info_svc_get_users returns error message in the result cluster

Created: 08/Nov/10 02:31 PM   Updated: 04/Feb/11 12:24 PM
Component/s: Engine
Affects Version/s: 2.1.3, 2.0.6
Fix Version/s: 2.1.4, 2.5.1, 2.0.7, 3.0 Alpha 1

Time Tracking:
Not Specified

File Attachments: 1. Zip Archive test_get_users.zip (884 kB)

Environment: SuperServer

Planning Status: Unspecified


 Description  « Hide
Bug was reported in devel by Cosmin Apreutesei.

When trying to request a just-created user I
get the error directly in the cluster, starting directly with the
error message. Is this a bug? If not, how can I parse this cluster?

This btw only happens with firebird 2.1.3 (2.5 doesn't do this), and
only immediately after I add the user TEST_USER with the following
parameters:

isc_spb_sec_username = 'TEST_USER',
isc_spb_sec_password = '1234',
isc_spb_sec_firstname = 'Test',
isc_spb_sec_middlename = 'W',
isc_spb_sec_lastname = 'User',
isc_spb_dbname = user_db_file,

This is the byte array I get (starting with code 68 which is
isc_info_svc_get_users, and ending in 1 which is eof -- the cluster
size is also right: 127 bytes).

68 D
127 
0
114 r
101 e
99 c
111 o
114 r
100 d
32
110 n
111 o
116 t
32
102 f
111 o
117 u
110 n
100 d
32
102 f
111 o
114 r
32
117 u
115 s
101 e
114 r
58 :
32
84 T
69 E
83 S
84 T
95 _
85 U
83 S
69 E
82 R
10

7
6
0
83 S
89 Y
83 S
68 D
66 B
65 A
10

3
0
83 S
113 q
108 l
11
6
0
83 S
101 e
114 r
118 v
101 e
114 r
12
13

0
65 A
100 d
109 m
105 i
110 n
105 i
115 s
116 t
114 r
97 a
116 t
111 o
114 r
5
0
0
0
0
6
0
0
0
0
7
9
0
84 T
69 E
83 S
84 T
95 _
85 U
83 S
69 E
82 R
10

4
0
84 T
101 e
115 s
116 t
11
1
0
87 W
12
4
0
85 U
115 s
101 e
114 r
5
0
0
0
0
6
0
0
0
0
1


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 08/Nov/10 02:32 PM
Bug takes place due to error message left in internal engine's buffer used to communicate with service thead.

Alexander Peshkov added a comment - 08/Nov/10 02:34 PM
This test case helps to reproduce a bug

Alexander Peshkov added a comment - 08/Nov/10 04:18 PM
Though bug did not show itself in fresh versions, cleaning up service output buffer is anyway correct idea.