Issue Details (XML | Word | Printable)

Key: CORE-3326
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Vlad Khorsun
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Fast mutex could be left in locked state by dead process

Created: 02/Feb/11 09:01 AM   Updated: 14/Feb/11 11:59 AM
Component/s: Engine
Affects Version/s: 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.5.0, 2.1.4
Fix Version/s: 2.5.1, 3.0 Alpha 1

Time Tracking:
Not Specified

Environment: Windows specific
Issue Links:
Replace
 

Planning Status: Unspecified


 Description  « Hide
If some process acquire fast mutex and died not releasing it it could hung all other activity.

Fast mutex was contributed by Yaffil team and integrated into Firebird 2.1. Since that time there was no reports about issues related to fast mutex robustness.
I reproduced hung in very specific scenario and only as result of another bug (see CORE-3325).

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Nickolay Samofatov added a comment - 02/Feb/11 01:01 PM
Well, the hanging happened quite regularly if you have 100's of users on a faulty network.
For Firebird 2.1 the hanging was reported once or twice a year per each 1000 connected users

CORE-3153 is the earlier incarnation of this bug

Vlad Khorsun added a comment - 02/Feb/11 02:17 PM
So far, you are the only one who reported such issue.
BTW, could you review the fix and, if possible, test it ?

Dmitry Yemanov added a comment - 02/Feb/11 04:58 PM
Shouldn't we close CORE-3153 as well?