Issue Details (XML | Word | Printable)

Key: CORE-3348
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Unassigned
Reporter: Artem Farafonov
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Server crash

Created: 11/Feb/11 08:11 PM   Updated: 23/Sep/15 12:17 PM
Component/s: Engine
Affects Version/s: 2.5.0
Fix Version/s: 2.5.1

Environment: Debian amd64/openvz, FirebirdCS-debuginfo-2.5.0.26074-0.amd64

QA Status: Not enough information


 Description  « Hide
Upgraded from 2.1 to 2.5 server worked perfectly for three weeks, but now it crashes 5-6 times a day. today i enabled debugging and coredump and got this stacktrace.


(gdb) backtrace
#0 0x00007fdbae4544aa in pthread_mutex_lock () from /lib/libpthread.so.0
#1 0x00007fdbaf3d94b1 in ISC_mutex_lock (mutex=0x7fdbacf78020) at ../src/jrd/isc_sync.cpp:2739
#2 0x00007fdbaf3950cb in Jrd::EventManager::acquire_shmem (this=0x7fdb97cb30d0) at ../src/jrd/event.cpp:529
#3 0x00007fdbaf395b1a in Jrd::EventManager::postEvent (this=0x7fdbacf78020, major_length=16,
    major_code=0x7fdb95e8a104 "\001\b", minor_length=22, minor_code=0x7fdb35b23eb0 "STATUS_CHANGED:beeline", count=1)
    at ../src/jrd/event.cpp:445
#4 0x00007fdbaf382120 in DFW_perform_post_commit_work (transaction=<value optimized out>) at ../temp/std/jrd/dfw.cpp:1271
#5 0x00007fdbaf45d998 in TRA_commit (tdbb=0x48e65230, transaction=0x7fdb35b24d30, retaining_flag=false)
    at ../src/jrd/tra.cpp:482
#6 0x00007fdbaf3def6b in commit (tdbb=0x48e65230, transaction=<value optimized out>, retaining_flag=<value optimized out>)
    at ../src/jrd/jrd.cpp:4304
#7 0x00007fdbaf3defe6 in JRD_commit_transaction (tdbb=0x7fdbacf78020, transaction=0x7fdb8376a308)
    at ../src/jrd/jrd.cpp:6413
#8 0x00007fdbaf3e5e68 in jrd8_commit_transaction (user_status=0x48e65ae0, tra_handle=0x7fdb8376a308)
    at ../src/jrd/jrd.cpp:1655
#9 0x00007fdbaf2b0ac4 in isc_commit_transaction (user_status=<value optimized out>, tra_handle=0x7fdb3f1458a0)
    at ../src/jrd/why.cpp:1733
#10 0x000000000040a2d7 in rem_port::end_transaction (this=0x7fdba1896260, operation=op_commit,
    release=<value optimized out>, sendL=0x7fdb9fd32c68) at ../src/remote/server.cpp:2024
#11 0x000000000040fd94 in process_packet (port=0x7fdba1896260, sendL=0x7fdb9fd32c68, receive=0x7fdb9fd33078,
    result=0x48e660a8) at ../src/remote/server.cpp:3375
#12 0x0000000000411947 in loopThread () at ../src/remote/server.cpp:5179
#13 0x00007fdbaf2a46d6 in threadStart (arg=0x7fdb71ab1528) at ../src/jrd/ThreadStart.cpp:128
#14 0x00007fdbae452fc7 in start_thread () from /lib/libpthread.so.0
#15 0x00007fdbae1c864d in clone () from /lib/libc.so.6
#16 0x0000000000000000 in ?? ()

I think this is related to this trigger:
CREATE OR ALTER trigger smsout_au0 for smsout
active after update position 0
AS
begin
  if (new.STATUS is distinct from old.STATUS) then
    post_event 'STATUS_CHANGED:' || new.GATEWAY_ID;
end


 All   Comments   Change History   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Dmitry Yemanov added a comment - 14/Feb/11 12:24 PM
Please test the snapshot build, the issue is supposedly fixed there.

Artem Farafonov added a comment - 15/Feb/11 10:25 PM
I think it is really fixed (no crash for 48 hours). Think bug can be closed now.