Issue Details (XML | Word | Printable)

Key: CORE-3397
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Alexander Peshkov
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Unresolved symbols in intl and trace libraries

Created: 18/Mar/11 05:46 PM   Updated: 23/Apr/13 11:49 AM
Component/s: None
Affects Version/s: 2.5.0
Fix Version/s: 2.5.1, 2.0.7, 2.1.5, 3.0 Alpha 1

Time Tracking:
Not Specified

Environment: Linux

Planning Status: Unspecified


 Description  « Hide
Due to use of RTLD_LAZY mode in ModuleLoader it happened to be possible to build libraries with unresolved references into gds.cpp.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 18/Mar/11 05:51 PM
The issue is specific for 2.5. Before it we did not have fbtrace at all and did not use gds__log() in fbintl. In FB3 all libraries are linked with fbclient, therefore they can't have unresolved gds_* symbols.

On the other hand, I've found it useful to load libraries in RTLD_NOW mode when doing DEV_BUILD for all branches to avoid such cases in the future.