Issue Details (XML | Word | Printable)

Key: CORE-3461
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Nickolay Samofatov
Votes: 3
Watchers: 4
Operations

If you were logged in you would be able to see more operations.
Firebird Core

DDL operations fail after backup/restore

Created: 04/May/11 11:28 PM   Updated: 23/Apr/13 12:03 PM
Component/s: None
Affects Version/s: 3.0 Initial, 2.0.6, 2.5.0, 2.1.4
Fix Version/s: 2.5.1, 2.1.5, 3.0 Alpha 1

Time Tracking:
Not Specified

File Attachments: 1. File messup.cmd (0.1 kB)
2. Text File messup1.sql (0.3 kB)
3. Text File messup2.sql (0.3 kB)


Planning Status: Unspecified


 Description  « Hide
Certain DDL operations work correctly when performed on freshly created database, and fail after backup/restore cycle.

The reason for failure is that system generators used to produce field names do not preserve their values during backup/restore cycle.
After backup/restore generated field names are no longer unique. Scripts to reproduce are attached.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Nickolay Samofatov added a comment - 04/May/11 11:30 PM
Test case. Run messup.cmd to see the failure:
Statement failed, SQLSTATE = 42000
unsuccessful metadata update
-cannot delete
-DOMAIN RDB$1
-there are 1 dependencies
After line 17 in file messup2.sql


If you remove backup/restore step from the script it will finish without errors

Alexander Peshkov added a comment - 01/Jun/11 09:37 AM
Existing solution can't be backported directly to B2_0.