Issue Details (XML | Word | Printable)

Key: CORE-3482
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Alexander Peshkov
Reporter: Vlad Khorsun
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
Firebird Core

nbackup ctrl-c segfaults and leaves db locked (delta file continues to grow)

Created: 17/May/11 08:49 AM   Updated: 23/Apr/13 12:06 PM
Component/s: Engine, NBACKUP
Affects Version/s: 3.0 Initial, 2.5.0
Fix Version/s: 2.5.1, 3.0 Alpha 1

Time Tracking:
Not Specified

Environment: Linux CS
Issue Links:
Depend
 

Planning Status: Unspecified


 Description  « Hide
The issue is reported by user privately. Seems Alex can confirm it.
The priority is minor as unlock database is very simple to do, so this is not an big issue.

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Alexander Peshkov added a comment - 25/May/11 11:49 AM
To make nbackup work correctly fix for CORE-3494 is also required

Alexander Peshkov added a comment - 25/May/11 01:03 PM
Added handler to process shutdown confirmation.
In FB3 problems with nbackup slightly differed, but solution from 2.5 is OK for them too.