Issue Details (XML | Word | Printable)

Key: CORE-3509
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Petr Gurin
Votes: 0
Watchers: 5
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Alter procedure allows to add the parameter with the same name.

Created: 03/Jun/11 10:35 AM   Updated: 08/Apr/14 02:42 PM
Component/s: Engine
Affects Version/s: 2.5.0
Fix Version/s: 2.5.1

Time Tracking:
Not Specified

Environment: Apperars on Windows and Linux operating system, affects Fb 2.5.0. Other operating system and I haven't tried
Issue Links:
Relate
 

Planning Status: Unspecified


 Description  « Hide
alter procedure allows to add input or output parameter with the same name. Selecting from procedure with such parameters crushes the server.

create or alter procedure Double_Params
returns
(ValueInt Integer)
as
begin
ValueInt = 1;
Suspend;
end;

Commit;

create or alter procedure Double_Params
returns
(ValueInt Integer,
ValueInt Integer)
as
begin
ValueInt = 1;
Suspend;
end;

Commit;

select * from Double_Params

 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Vlad Khorsun added a comment - 26/Jun/11 10:24 PM
Looks like regression in v2.5.

Both 2.1 and 3.0 throws

violation of PRIMARY or UNIQUE KEY constraint "RDB$INDEX_51" on table "RDB$PROCEDURE_PARAMETERS".

error (2.1 have another constraint name).