Issue Details (XML | Word | Printable)

Key: CORE-3521
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Vlad Khorsun
Reporter: Vlad Khorsun
Votes: 2
Watchers: 7
Operations

If you were logged in you would be able to see more operations.
Firebird Core

Delta file contents is not flushed to disk

Created: 15/Jun/11 11:20 AM   Updated: 23/Apr/13 01:00 PM
Component/s: Engine
Affects Version/s: 2.1.0, 2.0.4, 2.1.1, 2.0.5, 2.1.2, 2.1.3, 2.0.6, 2.5.0, 2.1.4
Fix Version/s: 2.5.1, 2.1.5, 3.0 Alpha 1

Time Tracking:
Not Specified

Issue Links:
Relate
 

Planning Status: Unspecified


 All   Comments   Work Log   Change History   Version Control   Subversion Commits      Sort Order: Ascending order - Click to sort in descending order
Robert Dollinger added a comment - 02/Dec/11 10:42 AM
Also the version 2.5.1 is affected! Is there any timeline when this bug will be fixed?

Dmitry Yemanov added a comment - 02/Dec/11 10:53 AM
How can you confirm that?

Vlad Khorsun added a comment - 02/Dec/11 11:09 AM
The fix already committed into v2.5.1
Ticket is not closed until backport into v2.1.5

Robert Dollinger added a comment - 02/Dec/11 11:35 AM
I have found the following lines in the firebird.log:

SVR04 Thu Dec 01 10:58:54 2011
                Database: D:\DATEN\DATABASE.FDB
                internal Firebird consistency check (page in use during flush (210), file: cch.cpp line: 2955)


SVR04 Thu Dec 01 10:58:55 2011
                Database: D:\DATEN\DATABASE.FDB
                internal Firebird consistency check (page in use during flush (210), file: cch.cpp line: 2955)


SVR04 Thu Dec 01 10:58:55 2011
                Database: D:\DATEN\DATABASE.FDB
                internal Firebird consistency check (page in use during flush (210), file: cch.cpp line: 2955)


SVR04 Thu Dec 01 10:58:58 2011
                INET/inet_error: read errno = 10054


SVR04 Thu Dec 01 10:58:58 2011
                INET/inet_error: read errno = 10054

Server Version: 2.5.1.26351 / SuperClassic / 32 Bit
Windows Server Standard 2008 64 Bit
Service Pack 2

Vlad Khorsun added a comment - 02/Dec/11 12:03 PM
1. Why do you think it is the same issue as in this ticket ?
2. Why do you think it is related to the nbackup ?
3. Are you able to reproduce it ?

Robert Dollinger added a comment - 02/Dec/11 01:07 PM
1. + 2. I don't really know if this is the same issue o related to nbackup. It sounds very similar to this open issue.
3. Actually I don't know how to reproduce it. It happend two times on the production system of one of my customers.

Which information about the crash do you need, so that you can determine if is a new issue or the same?

Dmitry Yemanov added a comment - 02/Dec/11 01:19 PM
Set BugcheckAbort = 1 in firebird.conf and restart the server. Set up DrWatson as documented here:
http://www.ibphoenix.com/resources/documents/development/doc_35

Once the server crashes due to a bugcheck, send us the DrWatson logs and dumps.

Robert Dollinger added a comment - 05/Dec/11 09:37 AM
Ok I will change the configuration of the firebird server. Where I have to send the logs and dumps?

Vlad Khorsun added a comment - 05/Dec/11 09:44 AM
Put it for download at any place you like and give us an url

Volker Rehn added a comment - 16/Mar/12 10:11 AM
Since it is the last registered Bug for 2.1.5 and one of two remaining for 2.5.1, I vote for it

Vlad Khorsun added a comment - 19/Mar/12 06:34 AM
Backported into v 2.1.5